Author Topic: Carburetor not getting fuel  (Read 142 times)

0 Members and 0 Guests are viewing this topic.

Offline shoesnsocks

  • 3 cube
  • *
  • Posts: 13
  • Karma: 2
Re: Carburetor not getting fuel
« on: July 15, 2017, 10:07:47 pm »
Finally figured out what was wrong with one of the units! It was a cs-280E. The carburetor's metering diaphragm doesn't have a metal disk, but there is supposed to be a separate plastic disk the goes between the diaphragm and the metering lever. I stupidly assumed that a new kit would come with the disk so I tossed it, then somehow didn't notice when I was putting it back together that there was no disk! Then come to find out there was no way to get the part, but was able to use some random diaphragm from a box of extra's. The saw now starts so easy a baby could start it!
Like Like x 1 Winner Winner x 1 View List

 

Related Topics

  Subject / Started by Replies Last post
14 Replies
446 Views
Last post December 28, 2013, 09:28:07 am
by SawTroll
2 Replies
132 Views
Last post February 26, 2014, 06:02:13 pm
by aclarke
7 Replies
315 Views
Last post May 24, 2014, 10:56:00 am
by KilliansRedLeo
6 Replies
174 Views
Last post July 18, 2014, 10:04:26 am
by srcarr52
8 Replies
316 Views
Last post July 22, 2014, 03:11:57 pm
by Cut4fun
14 Replies
634 Views
Last post March 25, 2016, 01:36:30 pm
by deezlfan
6 Replies
278 Views
Last post November 28, 2016, 09:18:58 pm
by mdavlee .
3 Replies
483 Views
Last post March 09, 2017, 06:22:06 am
by Jacks54
14 Replies
353 Views
Last post August 24, 2017, 12:35:06 am
by jmester
3 Replies
19 Views
Last post August 07, 2020, 05:50:41 pm
by changetires