Author Topic: Echo CS346-345  (Read 388 times)

0 Members and 0 Guests are viewing this topic.

Offline mountainlake

  • 5 cube
  • ***
  • Posts: 119
  • Karma: 21
Re: Echo CS346-345
« on: June 05, 2014, 06:57:21 am »

 It's possible you have bad coil but not likely , most likely a clogged  high speed circuit or a stiff diaphragm not pumping gas, or set too low.  If opening the high doesn't change the tune look for the above also check the gas lines for a pinhole or cracks.  Steve

 

Related Topics

  Subject / Started by Replies Last post
Echo 280

Started by Cut4fun . « 1 2 » Echo

10 Replies
1109 Views
Last post May 21, 2013, 03:48:18 pm
by Cut4fun .
2 Replies
576 Views
Last post February 06, 2012, 08:39:26 pm
by DB_43725
Echo 702

Started by Cut4fun . « 1 2 3 4 » Echo

32 Replies
2224 Views
Last post March 10, 2016, 03:44:56 pm
by Cut4fun .
Echo 452

Started by Cut4fun Echo

2 Replies
786 Views
Last post April 23, 2012, 11:19:35 pm
by DB_43725
Echo CS 60S

Started by Dh1984 Echo

4 Replies
1035 Views
Last post June 05, 2012, 06:33:11 pm
by Dh1984
2 Replies
844 Views
Last post October 15, 2012, 03:52:24 pm
by stroken56
1 Replies
279 Views
Last post October 27, 2012, 10:27:31 pm
by Al Smith
0 Replies
142 Views
Last post November 07, 2012, 08:50:19 am
by mweba
echo 5000

Started by Cut4fun . « 1 2 ... 5 6 » Echo

52 Replies
2067 Views
Last post January 01, 2016, 08:15:42 am
by old 040
Echo 290

Started by Cut4fun . Echo

1 Replies
279 Views
Last post September 19, 2013, 05:24:50 pm
by sharkey