Author Topic: New Echo CS-590 the chain smokes bad  (Read 1131 times)

0 Members and 0 Guests are viewing this topic.

Offline Kurt Sligh

  • 3 cube
  • *
  • Posts: 14
  • Karma: 1
  • Location: Union SC
Re: New Echo CS-590 the chain smokes bad
« on: September 21, 2015, 12:31:25 pm »
Insufficient oil, or a burned up roller tip.  Check the pump output without the bar and make sure the oil holes in the bar is not plugged

There was plenty of oil in it.  It's a brand new saw (maybe 6 hrs on it), so I doubt the roller tip would be burned up.  I'll take the bar off and see what I get.

My other 2 chainsaws are stihls, I decided to retire my big stihl after 11 years (worm gear or oil pump issue) and I went with the echo for economical reasons. I planned on repairing the stihl and having a backup.

Thanks,
Kurt

 

Related Topics

  Subject / Started by Replies Last post
0 Replies
694 Views
Last post June 12, 2012, 01:10:48 pm
by Dh1984
1 Replies
278 Views
Last post October 27, 2012, 10:27:31 pm
by Al Smith
Echo 290

Started by Cut4fun . Echo

1 Replies
277 Views
Last post September 19, 2013, 05:24:50 pm
by sharkey
2 Replies
549 Views
Last post July 13, 2015, 12:45:42 am
by Eccentric
7 Replies
290 Views
Last post October 06, 2014, 09:32:58 am
by rusted bolts
Echo 340 T

Started by Cut4fun . « 1 2 3 » Echo

27 Replies
1207 Views
Last post January 29, 2016, 09:06:32 pm
by Cut4fun .
6 Replies
423 Views
Last post July 31, 2015, 12:26:53 pm
by Cut4fun .
16 Replies
1134 Views
Last post June 26, 2015, 02:49:12 pm
by Tony G
2 Replies
421 Views
Last post September 08, 2015, 04:50:09 pm
by leec
echo cs-310

Started by Cut4fun . « 1 2 » Echo

11 Replies
662 Views
Last post March 24, 2016, 03:01:43 pm
by leec