Author Topic: 394 oil pump ?  (Read 347 times)

0 Members and 0 Guests are viewing this topic.

Offline KilliansRedLeo

  • Nitro Hotsaw
  • *******
  • Posts: 2361
  • Karma: 80
  • Location: Rochester, NY
    • RoCHusqvarna
Re: 394 oil pump ?
« Reply #10 on: November 23, 2013, 01:45:48 pm »
Yup, bar is on it. I yank the pimp apart and have a look see tonight. Just wondering if there were any parts that wear out and cause the problem. The saw feels like a beast Tim. I put a new piston and rings on it with the jug with the broken top fin.  There was some scoring on that jug. I cleaned it up as good as I can. It's at 130 psi, with no base gasket.

The compression will go up some when the rings seat. What piston and rings did you use?
"When the people fear the government...you have tyranny....When the government fears the people....you have liberty"

Thomas Jefferson
1743-1826

Offline alsled

  • Piped Saw
  • *****
  • Posts: 307
  • Karma: 18
Re: 394 oil pump ?
« Reply #11 on: November 23, 2013, 03:49:04 pm »
Tim its at 155 psi, I had the stupid de compression valve pushed in.  meteor piston and rings.

Offline KilliansRedLeo

  • Nitro Hotsaw
  • *******
  • Posts: 2361
  • Karma: 80
  • Location: Rochester, NY
    • RoCHusqvarna
Re: 394 oil pump ?
« Reply #12 on: November 23, 2013, 04:13:43 pm »
Learn something new every day. Compression will still go up from 155 after rings seat. You must have cleaned the cylinder up pretty well. Was the score below the exhaust port? If so that will not impact the saws performance.

The top cover for the 394 and the other bits will be at your place Monday.
"When the people fear the government...you have tyranny....When the government fears the people....you have liberty"

Thomas Jefferson
1743-1826

Offline alsled

  • Piped Saw
  • *****
  • Posts: 307
  • Karma: 18
Re: 394 oil pump ?
« Reply #13 on: November 23, 2013, 04:16:30 pm »
Mostly below, but slight scuffing above.

Offline KilliansRedLeo

  • Nitro Hotsaw
  • *******
  • Posts: 2361
  • Karma: 80
  • Location: Rochester, NY
    • RoCHusqvarna
Re: 394 oil pump ?
« Reply #14 on: November 23, 2013, 04:23:54 pm »
Well great! You should be able to go play in your buddy's wood pile in short order. 394XPs are truly a beast, with no base gasket and a muffler mod (did you dual port the muff?) she will really sing!  ;)
"When the people fear the government...you have tyranny....When the government fears the people....you have liberty"

Thomas Jefferson
1743-1826

Offline alsled

  • Piped Saw
  • *****
  • Posts: 307
  • Karma: 18
Re: 394 oil pump ?
« Reply #15 on: November 23, 2013, 07:43:04 pm »
Yup added another exhaust port on muffler.

 

Related Topics

  Subject / Started by Replies Last post
2 Replies
1504 Views
Last post July 15, 2012, 07:13:26 am
by farmboy
5 Replies
257 Views
Last post December 03, 2012, 02:16:45 pm
by Cut4fun
55 Replies
7876 Views
Last post September 21, 2015, 07:42:19 pm
by mikehonda
7 Replies
370 Views
Last post October 15, 2013, 08:14:57 pm
by jmester
7 Replies
272 Views
Last post November 22, 2013, 02:02:14 pm
by Cut4fun .
6 Replies
353 Views
Last post November 10, 2013, 07:13:26 am
by rayvil01
14 Replies
705 Views
Last post December 18, 2017, 06:48:12 pm
by Cut4fun .
5 Replies
718 Views
Last post January 25, 2014, 03:07:17 pm
by Infinitive
28 Replies
496 Views
Last post July 19, 2017, 07:45:14 am
by Nixon
3 Replies
153 Views
Last post June 04, 2019, 08:36:12 am
by ray benson