Author Topic: k760 runs great but strange problem  (Read 106 times)

0 Members and 0 Guests are viewing this topic.

Offline martang

  • pruner
  • *
  • Posts: 2
  • Karma: 0
k760 runs great but strange problem
« on: May 04, 2020, 12:54:44 pm »
my k760 saw runs very well but when it's not in use it leaks fuel, from directly underneath the throttle trigger a constant slow leak of fuel and it doesn't stop until tank is empty. I've had the carb out a few times now fitted new fuel pipes new fuel pressure bubble cleaned everything but still the problem exists. Anyone have any ideas?

Share on Facebook Share on Twitter


Offline martang

  • pruner
  • *
  • Posts: 2
  • Karma: 0
k760 leaking fuel while not being used ??
« Reply #1 on: May 04, 2020, 02:18:04 pm »
my husqvarna k760 runs great but when its not in use it slowly leaks fuel from directly underneath the throttle trigger, it does this constantly until fuel tank is empty. I have put new fuel pipes on and cleaned everything but it continues to leak.  Any thoughts welcome !

Offline Cut4fun .

  • Administrator
  • Nitro Hotsaw
  • *******
  • Posts: 22126
  • Karma: 551
  • OHIO REDNECK Saw Repair Getter Done
    • Redneck Chainsaw Repair
Re: k760 runs great but strange problem
« Reply #2 on: May 04, 2020, 03:44:23 pm »
IPL https://www.ereplacementparts.com/husqvarna-k760-power-cutter-parts-c-114486_118655_198127.html

Leaking past the tank vent #7.  I dont know the saw so just using IPL pic for area.   @3000 FPS is this one the saws you been in?
REDNECK Saw Repair Getter Done

Offline 3000 FPS

  • Moderator
  • Nitro Hotsaw
  • *******
  • Posts: 4478
  • Karma: 275
  • Location: Carpenter, Wyoming
Re: k760 runs great but strange problem
« Reply #3 on: May 04, 2020, 06:40:46 pm »
IPL https://www.ereplacementparts.com/husqvarna-k760-power-cutter-parts-c-114486_118655_198127.html

Leaking past the tank vent #7.  I dont know the saw so just using IPL pic for area.   @3000 FPS is this one the saws you been in?

I worked on some the K760 saws when I working part time before retiring.     I agree with cut4fun that it could be the tank vent.   
I have a K960 here at home that I got free and completely rebuilt it.     


PP 505, 475, 445.
Like Like x 1 View List

Offline 3000 FPS

  • Moderator
  • Nitro Hotsaw
  • *******
  • Posts: 4478
  • Karma: 275
  • Location: Carpenter, Wyoming
Re: k760 runs great but strange problem
« Reply #4 on: May 04, 2020, 06:43:15 pm »
Picture of the K960 I have.

PP 505, 475, 445.
Like Like x 1 View List

Online ray benson

  • 5 cube
  • ***
  • Posts: 135
  • Karma: 66
  • Retired Industrial Electrician
  • Location: Indiana
Re: k760 leaking fuel while not being used ??
« Reply #5 on: May 05, 2020, 09:30:13 am »
my husqvarna k760 runs great but when its not in use it slowly leaks fuel from directly underneath the throttle trigger, it does this constantly until fuel tank is empty. I have put new fuel pipes on and cleaned everything but it continues to leak.  Any thoughts welcome !

Check your messages for an ipl and service manual
Like Like x 1 Useful Useful x 1 View List

 

Related Topics

  Subject / Started by Replies Last post
13 Replies
941 Views
Last post March 09, 2012, 01:51:34 pm
by eli-dream
0 Replies
661 Views
Last post May 05, 2012, 12:12:10 am
by fordfairlane78
34 Replies
3975 Views
Last post August 02, 2014, 04:07:59 pm
by 630 red
8 Replies
432 Views
Last post August 26, 2014, 12:14:10 am
by stihls066
6 Replies
225 Views
Last post August 25, 2014, 09:19:02 am
by Cut4fun .
6 Replies
276 Views
Last post May 09, 2016, 05:25:47 am
by Al Smith
2 Replies
125 Views
Last post September 15, 2017, 10:04:32 pm
by joe_indi
1 Replies
152 Views
Last post September 18, 2017, 08:38:44 pm
by 3000 FPS
2 Replies
173 Views
Last post October 30, 2017, 06:53:53 pm
by 3000 FPS
2 Replies
159 Views
Last post October 23, 2018, 09:19:10 pm
by leec