Author Topic: Husky 435 - runs, but chain not moving  (Read 295 times)

0 Members and 0 Guests are viewing this topic.

Offline yokesoverez

  • pruner
  • *
  • Posts: 4
  • Karma: 0
Re: Husky 435 - runs, but chain not moving
« Reply #10 on: October 27, 2013, 08:15:53 pm »
Yes, I should have tried it by hand before starting, but I assumed.....

Also, very familiar with chain brake - used many chainsaws in the past, which is why I was so sure of myself. Will be taking it back in to the shop tomorrow for professional fixing since it is beyond my skills.  Thanks to all who have responded.

Offline 660magnum

  • Global Moderator
  • Nitro Hotsaw
  • *******
  • Posts: 6437
  • Karma: 249
  • For The Love Of Chainsaws
  • Location: NCO
Re: Husky 435 - runs, but chain not moving
« Reply #11 on: October 27, 2013, 08:34:28 pm »
We all have lived and learned
We should share what we know... someone may learn...
That knowledge can live after us... and that "Pays It Forward".
Be all that you can be . . .

Offline Bluegill

  • 5 cube
  • ***
  • Posts: 141
  • Karma: 22
Re: Husky 435 - runs, but chain not moving
« Reply #12 on: October 29, 2013, 02:12:13 pm »
I sure have screwed up some stuff in the past, but all good learning from that...

 

Related Topics

  Subject / Started by Replies Last post
6 Replies
586 Views
Last post March 15, 2011, 10:39:08 pm
by wannab12
0 Replies
214 Views
Last post March 11, 2011, 07:26:49 pm
by Cut4fun
13 Replies
944 Views
Last post March 09, 2012, 01:51:34 pm
by eli-dream
22 Replies
784 Views
Last post October 05, 2012, 10:17:28 pm
by Al Smith
3 Replies
323 Views
Last post December 19, 2012, 12:52:30 am
by 660magnum
4 Replies
256 Views
Last post May 15, 2013, 07:54:16 pm
by SawTroll
4 Replies
256 Views
Last post August 12, 2013, 10:10:23 pm
by Cut4fun
1 Replies
211 Views
Last post November 03, 2013, 03:11:25 pm
by Cut4fun .
8 Replies
369 Views
Last post April 12, 2016, 12:37:06 am
by 67L36Driver
5 Replies
111 Views
Last post May 05, 2020, 09:30:13 am
by ray benson