Author Topic: Husq 350 only runs with top cover off!!! Help!  (Read 323 times)

0 Members and 0 Guests are viewing this topic.

Offline 660magnum

  • Global Moderator
  • Nitro Hotsaw
  • *******
  • Posts: 6437
  • Karma: 249
  • For The Love Of Chainsaws
  • Location: NCO
Re: Husq 350 only runs with top cover off!!! Help!
« on: December 18, 2012, 04:15:52 pm »
It has air and fuel problems

Air leak around the intake boot where it fastens to the cylinder most likely?

It has gone on so long now that the piston is galled at the exhaust port? Remove the muffler and look at the piston to see if there are scratches on it?
We should share what we know... someone may learn...
That knowledge can live after us... and that "Pays It Forward".
Be all that you can be . . .

 

Related Topics

  Subject / Started by Replies Last post
6 Replies
586 Views
Last post March 15, 2011, 10:39:08 pm
by wannab12
13 Replies
944 Views
Last post March 09, 2012, 01:51:34 pm
by eli-dream
22 Replies
784 Views
Last post October 05, 2012, 10:17:28 pm
by Al Smith
2 Replies
420 Views
Last post November 24, 2013, 08:37:21 pm
by alsled
1 Replies
180 Views
Last post April 06, 2014, 01:26:38 pm
by KilliansRedLeo
15 Replies
339 Views
Last post June 05, 2014, 01:17:33 pm
by Eliott
13 Replies
282 Views
Last post December 22, 2014, 01:50:28 am
by 660magnum
14 Replies
391 Views
Last post November 24, 2016, 03:59:02 pm
by Eccentric
0 Replies
288 Views
Last post January 27, 2017, 04:19:54 pm
by waltergorman
5 Replies
111 Views
Last post May 05, 2020, 09:30:13 am
by ray benson