Author Topic: husky 570 starts but bogs bad  (Read 157 times)

0 Members and 0 Guests are viewing this topic.

Offline joel4bs

  • pruner
  • *
  • Posts: 3
  • Karma: 1
husky 570 starts but bogs bad
« on: March 29, 2018, 05:50:07 pm »
carb  gaskets replaced ..saw starts well...idles well...but bogs bad when triggers is pulled...I am about ready to bring it for repair, but would be glad to do the work myself if anyone here has a good plan...saw was running great ...strong etc not long ago.

Share on Facebook Share on Twitter


Offline Cut4fun .

  • Administrator
  • Nitro Hotsaw
  • *******
  • Posts: 21944
  • Karma: 531
  • OHIO REDNECK Saw Repair Getter Done
    • Redneck Chainsaw Repair
Re: husky 570 starts but bogs bad
« Reply #1 on: March 29, 2018, 07:47:06 pm »
Open L up on carb.
REDNECK Saw Repair Getter Done
Like Like x 1 View List

Offline joel4bs

  • pruner
  • *
  • Posts: 3
  • Karma: 1
Re: husky 570 starts but bogs bad
« Reply #2 on: March 29, 2018, 08:26:08 pm »
I will try that again, Thanks

Offline Cut4fun .

  • Administrator
  • Nitro Hotsaw
  • *******
  • Posts: 21944
  • Karma: 531
  • OHIO REDNECK Saw Repair Getter Done
    • Redneck Chainsaw Repair
Re: husky 570 starts but bogs bad
« Reply #3 on: March 30, 2018, 06:17:00 am »
I cant remember if the 570 had some kind of epa stops on the H and L or not.  Do you have full adjustment all the way in and out?

IPL shows yes there appears to be the plastic tab stops on them. Need to trim them off to give full adjustments.  Page 15 on mine.

Husqvarna 570 575 IPL  http://s30387.gridserver.com/partsDiagrams/Husqvarna%20570%20and%20575.pdf
REDNECK Saw Repair Getter Done

Offline joel4bs

  • pruner
  • *
  • Posts: 3
  • Karma: 1
Re: husky 570 starts but bogs bad
« Reply #4 on: March 30, 2018, 10:35:37 am »
The previous owner of the saw must have taken the stops off...I am able to adjust the L and H fully both in and out.
I inherited this saw from an old old friend who died last year...(nothing to do with the saw)...he always kept it running well...and I feel bad that it is not now...
by the way, the black etched plate thing seems to indicate that it is a 2009

 

Related Topics

  Subject / Started by Replies Last post
13 Replies
934 Views
Last post March 09, 2012, 01:51:34 pm
by eli-dream
17 Replies
696 Views
Last post February 12, 2013, 07:48:58 am
by bassman
6 Replies
303 Views
Last post June 16, 2013, 08:56:25 am
by Al Smith
16 Replies
432 Views
Last post December 27, 2013, 05:37:28 am
by 660magnum
7 Replies
444 Views
Last post October 29, 2014, 03:58:59 pm
by Fish
15 Replies
426 Views
Last post January 23, 2015, 02:03:24 pm
by Bluegill
7 Replies
183 Views
Last post March 11, 2015, 08:20:37 pm
by 660magnum
21 Replies
624 Views
Last post September 14, 2015, 06:21:22 pm
by jeff.lary
2 Replies
215 Views
Last post July 04, 2018, 08:14:36 am
by Cut4fun .
3 Replies
140 Views
Last post September 12, 2018, 03:41:52 pm
by bsaumph