Author Topic: Replaced piston/cylinder now won't fire  (Read 1766 times)

0 Members and 0 Guests are viewing this topic.

Offline wbhburn

  • 3 cube
  • *
  • Posts: 24
  • Karma: 0
Re: Replaced piston/cylinder now won't fire
« Reply #20 on: October 26, 2013, 01:39:49 pm »
I removed everything required to do the vacuum test but I did not have enough hands to hold the saw, reach the impulse tube, pump in the air from the syringe and check for leaks at the same time. However, I did a very close inspection and saw no areas around the case gasket that could be leaking. I "orally" checked the I manifold and determined it held pressure (no leaks). Reassembled and still no fire. Spark looks good and strong. Questions...

Even if there is a pin hole leak somewhere in the case wouldn't it at least fire?
How can I "prime the thing" just to get it to fire once?
Do I add a bit of gas in the carb throat or in the plug hole? I just want to hear it fire once :-)
I'm willing to up-grade to the new carb and manifold Cut4fun suggested. Where to purchase?
If it was running before could the old carb/manifold really be the problem?

 

Related Topics

  Subject / Started by Replies Last post
2 Replies
518 Views
Last post August 04, 2011, 08:04:28 pm
by Old Iron Logging
28 Replies
2166 Views
Last post February 16, 2012, 06:58:36 am
by brokenbudget
12 Replies
936 Views
Last post January 26, 2012, 09:09:40 am
by ECpirates96
0 Replies
322 Views
Last post May 24, 2012, 08:20:22 pm
by MP5N
20 Replies
3194 Views
Last post March 18, 2022, 07:56:44 am
by Cut4fun .
63 Replies
3145 Views
Last post October 26, 2013, 05:32:17 pm
by davbell22602
19 Replies
980 Views
Last post September 09, 2013, 09:51:10 pm
by doreadeal
40 Replies
1549 Views
Last post December 20, 2013, 01:00:22 pm
by Spike60
17 Replies
801 Views
Last post May 12, 2014, 12:40:25 am
by sharkey
21 Replies
1171 Views
Last post November 29, 2014, 08:29:17 am
by weimedog