Author Topic: McCulloch oil pump problem  (Read 8000 times)

0 Members and 2 Guests are viewing this topic.

Offline qwerty12

  • 4 cube
  • **
  • Posts: 31
  • Karma: 1
Re: McCulloch oil pump problem
« on: April 07, 2013, 02:03:33 pm »
Well...I assambled the chainsaw today. Oil pump to. Cleaned ewerything to perfection...still got no oil on the chain bar and chain.

Something strange happens all the time. On the oil cap side,bellow the exhaust, there is a small bleed hole wich serves as air inlet hole as oil is getting used and dissapears. On that werry hole when I press full trottle oil is comming out it bublles if oil tank is full... Buth on the chain side a hole which should be draining oil hotthing happens. No oil.

Checked all holes, cleaned them. Made new gaskets. Tryed ewerything. And no oil on chain. :(

Please help, i am getting disenchanted totally




EDIT:

Here are few oil pump pictures beffore cleaning:





 

Related Topics

  Subject / Started by Replies Last post
2 Replies
1515 Views
Last post July 15, 2012, 07:13:26 am
by farmboy
4 Replies
997 Views
Last post April 02, 2012, 09:31:29 am
by 2spud
2 Replies
296 Views
Last post July 19, 2012, 08:02:44 pm
by Cut4fun .
5 Replies
261 Views
Last post December 03, 2012, 02:16:45 pm
by Cut4fun
7 Replies
418 Views
Last post October 15, 2013, 08:14:57 pm
by jmester
7 Replies
272 Views
Last post November 22, 2013, 02:02:14 pm
by Cut4fun .
6 Replies
361 Views
Last post November 10, 2013, 07:13:26 am
by rayvil01
394 oil pump ?

Started by alsled « 1 2 » Husqvarna

15 Replies
349 Views
Last post November 23, 2013, 07:43:04 pm
by alsled
14 Replies
723 Views
Last post December 18, 2017, 06:48:12 pm
by Cut4fun .
3 Replies
270 Views
Last post June 04, 2016, 04:09:27 am
by Le Maisonniau