Author Topic: McCulloch oil pump problem  (Read 7995 times)

0 Members and 2 Guests are viewing this topic.

Offline brokenbudget

  • Nitro Hotsaw
  • *******
  • Posts: 900
  • Karma: 67
  • Location: brockville ontario canada
Re: McCulloch oil pump problem
« Reply #10 on: April 07, 2013, 09:27:42 pm »
when you instal the oiler, are you sure the rubber gasket is fully seated? it could be it's getting old and not sealing.
this one: http://postimg.org/image/zeu9sl5ez/

i bet whats happening is the pump is sucking air from the top of the tank, because that gasket would sort of be above the oil level and not feeding the pump. then it just pumping a small amount of oil with a whole lot of air, not making it out to the bar but blowing back into the tank.
that rubber gasket should be a tight fit between the pump housing and the tank top.
when I grow up, i wanna be an adult.

 

Related Topics

  Subject / Started by Replies Last post
2 Replies
1515 Views
Last post July 15, 2012, 07:13:26 am
by farmboy
4 Replies
997 Views
Last post April 02, 2012, 09:31:29 am
by 2spud
2 Replies
296 Views
Last post July 19, 2012, 08:02:44 pm
by Cut4fun .
5 Replies
261 Views
Last post December 03, 2012, 02:16:45 pm
by Cut4fun
7 Replies
416 Views
Last post October 15, 2013, 08:14:57 pm
by jmester
7 Replies
272 Views
Last post November 22, 2013, 02:02:14 pm
by Cut4fun .
6 Replies
361 Views
Last post November 10, 2013, 07:13:26 am
by rayvil01
394 oil pump ?

Started by alsled « 1 2 » Husqvarna

15 Replies
349 Views
Last post November 23, 2013, 07:43:04 pm
by alsled
14 Replies
723 Views
Last post December 18, 2017, 06:48:12 pm
by Cut4fun .
3 Replies
270 Views
Last post June 04, 2016, 04:09:27 am
by Le Maisonniau