Author Topic: McCulloch oil pump problem  (Read 7987 times)

0 Members and 5 Guests are viewing this topic.

Offline brokenbudget

  • Nitro Hotsaw
  • *******
  • Posts: 900
  • Karma: 67
  • Location: brockville ontario canada
Re: McCulloch oil pump problem
« Reply #40 on: June 15, 2013, 08:28:48 pm »
looking at another thread on another site, i think you're missing a ball and spring. it would be the "other" check valve.
notice the "large" spring. right beside it, notice the ball. under that ball is a spring. seems yours is missing.


edit: thought i put this pic in :)
seems the little ball is missing :( not where the arrow is pointing.

when I grow up, i wanna be an adult.

 

Related Topics

  Subject / Started by Replies Last post
2 Replies
1515 Views
Last post July 15, 2012, 07:13:26 am
by farmboy
4 Replies
996 Views
Last post April 02, 2012, 09:31:29 am
by 2spud
2 Replies
293 Views
Last post July 19, 2012, 08:02:44 pm
by Cut4fun .
5 Replies
260 Views
Last post December 03, 2012, 02:16:45 pm
by Cut4fun
7 Replies
413 Views
Last post October 15, 2013, 08:14:57 pm
by jmester
7 Replies
272 Views
Last post November 22, 2013, 02:02:14 pm
by Cut4fun .
6 Replies
361 Views
Last post November 10, 2013, 07:13:26 am
by rayvil01
394 oil pump ?

Started by alsled « 1 2 » Husqvarna

15 Replies
349 Views
Last post November 23, 2013, 07:43:04 pm
by alsled
14 Replies
723 Views
Last post December 18, 2017, 06:48:12 pm
by Cut4fun .
3 Replies
269 Views
Last post June 04, 2016, 04:09:27 am
by Le Maisonniau