Author Topic: McCulloch oil pump problem  (Read 7987 times)

0 Members and 5 Guests are viewing this topic.

Offline brokenbudget

  • Nitro Hotsaw
  • *******
  • Posts: 900
  • Karma: 67
  • Location: brockville ontario canada
Re: McCulloch oil pump problem
« Reply #40 on: June 16, 2013, 08:25:05 am »
i've had my share of 10-10's, 700's, 850's etc. with bad pumps. i'm a guy that has no problem drop starting an 088 without the decomp, but when one of those 10 series had any type of oil in them they just wouldn't budge :) of course, it was always when you never expected it so you'd just grab on that pull handle to give her a twist only to find out in a spit second how painful it can be when that cord don't want to come out. can't tell you how many times i've either broken the cord, handle or pulled that handle out of my hand over extending a couple few fingers in the process. damn near make me want to cry like a baby. and them fingers are frikin sore for the rest of the day and week.
good thing today most saws have extrenal pumps and can't really ingest chain oil. i don't think the starters would be up for the abuse.
when I grow up, i wanna be an adult.

 

Related Topics

  Subject / Started by Replies Last post
2 Replies
1515 Views
Last post July 15, 2012, 07:13:26 am
by farmboy
4 Replies
996 Views
Last post April 02, 2012, 09:31:29 am
by 2spud
2 Replies
293 Views
Last post July 19, 2012, 08:02:44 pm
by Cut4fun .
5 Replies
260 Views
Last post December 03, 2012, 02:16:45 pm
by Cut4fun
7 Replies
413 Views
Last post October 15, 2013, 08:14:57 pm
by jmester
7 Replies
272 Views
Last post November 22, 2013, 02:02:14 pm
by Cut4fun .
6 Replies
361 Views
Last post November 10, 2013, 07:13:26 am
by rayvil01
394 oil pump ?

Started by alsled « 1 2 » Husqvarna

15 Replies
349 Views
Last post November 23, 2013, 07:43:04 pm
by alsled
14 Replies
723 Views
Last post December 18, 2017, 06:48:12 pm
by Cut4fun .
3 Replies
269 Views
Last post June 04, 2016, 04:09:27 am
by Le Maisonniau