Author Topic: What model of JD chainsaw is this on CL?  (Read 697 times)

0 Members and 0 Guests are viewing this topic.

Offline winland

  • 6 cube
  • ****
  • Posts: 215
  • Karma: 24
  • Location: 44883
    • Winland Boxers

Social Buttons


Offline Cut4fun .

  • Administrator
  • Nitro Hotsaw
  • *******
  • Posts: 17724
  • Karma: 333
  • OHIO REDNECK Saw Repair Getter Done
    • Redneck Chainsaw Repair
REDNECK Saw Repair Getter Done

Offline winland

  • 6 cube
  • ****
  • Posts: 215
  • Karma: 24
  • Location: 44883
    • Winland Boxers
Re: What model of JD chainsaw is this on CL?
« Reply #2 on: December 23, 2013, 03:21:48 pm »
Thanks

Offline Cut4fun .

  • Administrator
  • Nitro Hotsaw
  • *******
  • Posts: 17724
  • Karma: 333
  • OHIO REDNECK Saw Repair Getter Done
    • Redneck Chainsaw Repair
Re: What model of JD chainsaw is this on CL?
« Reply #3 on: December 25, 2013, 08:25:06 pm »
I see your looking for a flywheel for it. So you got this one?  Start, run, cut?    What was it doing to need a flywheel?
REDNECK Saw Repair Getter Done

Offline winland

  • 6 cube
  • ****
  • Posts: 215
  • Karma: 24
  • Location: 44883
    • Winland Boxers
Re: What model of JD chainsaw is this on CL?
« Reply #4 on: December 26, 2013, 07:36:46 am »
Can not start it.
When you pull the starter rope it just spins.
The starter pawls (ratchets) are not catching on the recoil drum.
Also the pawls are hitting the flywheel fins.
The pawl springs seem to be "sprung" stretched out.
Not sure exactly how they are suppose to be installed.
Looks like someone has been working on it before and the pawls and springs may have been installed wrong.
I have found the IPL for the Echo 650.

Chuck

Offline fordfairlane78

  • 6 cube
  • ****
  • Posts: 160
  • Karma: 16
  • Location: Valley Center,KS
Re: What model of JD chainsaw is this on CL?
« Reply #5 on: December 29, 2013, 11:23:57 am »
You may still have problems with the pawls but as far as the starter not engaging on this model of saw is usually worn out body mounts.  Had a couple 660's that would both skip when pull starting. A local shop tried to put a shim behind the flywheel. I told them I thought the mounts where worn out causing to much flex of the starter away from the flywheel. Anyway shim didn't work and of course no refund so I made my own mounts using longer bolts through rubber plugs and it fixed both saws...
Trapped in time, surrounded by evil, low on gas

 

Related Topics

  Subject / Started by Replies Last post
97 Replies
1539 Views
Last post September 18, 2013, 07:29:28 pm
by davbell22602
Which model

Started by fossil « 1 2 » Poulan

14 Replies
269 Views
Last post October 30, 2013, 10:11:05 pm
by AmericanPsycho
5 Replies
155 Views
Last post February 24, 2014, 04:29:30 pm
by fordrocks
8 Replies
340 Views
Last post April 11, 2014, 12:40:29 am
by brettl
6 Replies
127 Views
Last post October 27, 2014, 08:56:29 am
by 660magnum
3 Replies
546 Views
Last post February 27, 2015, 05:36:20 pm
by Cut4fun
8 Replies
238 Views
Last post April 12, 2016, 12:37:06 am
by 67L36Driver
15 Replies
348 Views
Last post April 15, 2016, 03:53:16 pm
by Model 51
4 Replies
155 Views
Last post April 29, 2016, 02:11:10 pm
by Rod in MN
1 Replies
108 Views
Last post December 05, 2016, 11:26:48 am
by Cut4fun .