Author Topic: Oil seals on Stihl MS660 keep going bad.  (Read 242 times)

0 Members and 0 Guests are viewing this topic.

Offline emhusq66

  • 3 cube
  • *
  • Posts: 5
  • Karma: 2
Re: Oil seals on Stihl MS660 keep going bad.
« on: December 30, 2019, 09:31:45 am »
First thank you for getting back to me so quickly I might check the impluse line regardless of the new parts. The impulse line is brand new and so are the main bearings which I put in myself. Pretty much I tore the whole thing down and replaced everything I could, I also added the big bore kit (56mm) and was planning on buying a Hyway pop-up piston for the bigbore until all this happened.
Useful Useful x 1 View List

 

Related Topics

  Subject / Started by Replies Last post
2 Replies
225 Views
Last post March 13, 2012, 08:20:33 pm
by 660magnum
4 Replies
130 Views
Last post August 31, 2013, 03:22:53 pm
by Fish
ms660

Started by don5477 Stihl

7 Replies
278 Views
Last post December 30, 2013, 12:51:57 pm
by Fish
1 Replies
304 Views
Last post February 05, 2014, 08:38:42 pm
by Cut4fun .
7 Replies
174 Views
Last post September 12, 2014, 07:50:51 pm
by 660magnum
0 Replies
67 Views
Last post February 04, 2015, 10:27:58 am
by farmboy
20 Replies
1315 Views
Last post May 19, 2017, 04:08:15 am
by sharkey
1 Replies
69 Views
Last post March 02, 2016, 10:15:56 pm
by Ozarker
3 Replies
124 Views
Last post December 12, 2017, 09:40:25 pm
by sawyer tom
Stihl 066 660 MS660

Started by Cut4fun . « 1 2 3 » Stihl

29 Replies
1038 Views
Last post May 02, 2020, 02:36:33 pm
by Cut4fun .