Author Topic: rebuilt 066 wont run  (Read 360 times)

0 Members and 0 Guests are viewing this topic.

Offline fordrocks

  • 4 cube
  • **
  • Posts: 46
  • Karma: 2
rebuilt 066 wont run
« on: February 17, 2014, 04:18:32 pm »
I just rebuilt an 066 from a few parts saws. Put in a new piston, spark plug, fuel filter. It has great spark and compression. When i try to start it i just get the odd backfire. Just can't get it to turn over! I changed the ignition and the carb but get the same result. I've rebuilt several of these and never had this problem.  Any ideas?????? ???

Share on Facebook Share on Twitter


Offline KilliansRedLeo

  • Nitro Hotsaw
  • *******
  • Posts: 2361
  • Karma: 80
  • Location: Rochester, NY
    • RoCHusqvarna
Re: rebuilt 066 wont run
« Reply #1 on: February 17, 2014, 04:25:44 pm »
Did the saw pass pressure/vac test? What brand spark plug? (Have seen a lot of NGKs bad out of the box lately). Will it fire if you squirt a little fuel in the carburetor? If it will, then there is some sort of fuel delivery issue, perhaps a collapsed or pinched fuel line.
"When the people fear the government...you have tyranny....When the government fears the people....you have liberty"

Thomas Jefferson
1743-1826

Offline aclarke

  • Nitro Hotsaw
  • *******
  • Posts: 1676
  • Karma: 172
Re: rebuilt 066 wont run
« Reply #2 on: February 17, 2014, 04:35:03 pm »
Had a similar issue on a 362. Loose electrode on New plug, Denso

Offline Fish

  • Piped Saw
  • *****
  • Posts: 309
  • Karma: 39
Re: rebuilt 066 wont run
« Reply #3 on: February 17, 2014, 04:39:56 pm »
Look and see if the flywheel key is sheared or not.

Online 3000 FPS

  • Moderator
  • Nitro Hotsaw
  • *******
  • Posts: 4478
  • Karma: 275
  • Location: Carpenter, Wyoming
Re: rebuilt 066 wont run
« Reply #4 on: February 17, 2014, 04:42:24 pm »
When trying to start it pull the plug to see if it is wet or dry.   If dry put some fuel mix into the carb.  If wet it is flooded.   Are you getting any kick back on the starter when pulling it.  Just thinking of a possible timing issue.
PP 505, 475, 445.

Offline fordrocks

  • 4 cube
  • **
  • Posts: 46
  • Karma: 2
Re: rebuilt 066 wont run
« Reply #5 on: February 17, 2014, 06:56:58 pm »
it's getting fuel because it does backfire with flames out of the muffler, almost feels like a timing issue because it backfires every 2 or 3 pulls. Haven't done a pressure/vac test. And i have tries 2 different plugs.

Online 3000 FPS

  • Moderator
  • Nitro Hotsaw
  • *******
  • Posts: 4478
  • Karma: 275
  • Location: Carpenter, Wyoming
Re: rebuilt 066 wont run
« Reply #6 on: February 17, 2014, 07:05:15 pm »
it's getting fuel because it does backfire with flames out of the muffler, almost feels like a timing issue because it backfires every 2 or 3 pulls. Haven't done a pressure/vac test. And i have tries 2 different plugs.

I think your correct the timing sounds off.   

Did you put a different coil on it ?    Also like Fish mentioned earlier, Check the flywheel key.
PP 505, 475, 445.

Offline mdavlee .

  • Global Moderator
  • Nitro Hotsaw
  • *******
  • Posts: 1968
  • Karma: 171
Re: rebuilt 066 wont run
« Reply #7 on: February 17, 2014, 07:33:29 pm »
Which coil an flywheel did you use?

Offline roostersgt

  • 3 cube
  • *
  • Posts: 24
  • Karma: 1
  • Location: 5200' Cali
Re: rebuilt 066 wont run
« Reply #8 on: February 17, 2014, 08:36:46 pm »
as suggested already, change to different coil. they had numerous coils for the 064/066/660. some have diferent timing than others and the flywheel must match the coil,or itll rip the rope out of your hand and backfire etc.....
You didn't win silver, you lost gold.

Offline fordrocks

  • 4 cube
  • **
  • Posts: 46
  • Karma: 2
Re: rebuilt 066 wont run
« Reply #9 on: February 17, 2014, 11:13:49 pm »
I've tried a 2 bolt coil and a 3 bolt coil with the same results. I'm using the metal flywheel. I'll try another coil tomorrow if i have a different one.

 

Related Topics

  Subject / Started by Replies Last post
9 Replies
1191 Views
Last post November 05, 2014, 10:35:55 pm
by 67L36Driver
13 Replies
384 Views
Last post November 04, 2013, 05:27:49 am
by alsled
5 Replies
311 Views
Last post April 13, 2014, 11:22:26 am
by KilliansRedLeo
4 Replies
281 Views
Last post July 12, 2014, 05:55:01 pm
by KilliansRedLeo
MS360 Pro wont start

Started by ears54 « 1 2 » Stihl

10 Replies
505 Views
Last post August 16, 2015, 03:37:13 pm
by Cut4fun .
2 Replies
193 Views
Last post September 12, 2015, 09:44:05 pm
by jrdplowing
36 Replies
1532 Views
Last post February 11, 2016, 11:17:11 am
by 3000 FPS
2 Replies
381 Views
Last post December 30, 2015, 03:58:15 pm
by Cat-Face Timber
10 Replies
495 Views
Last post April 09, 2017, 03:28:22 pm
by HolmenTree
11 Replies
1911 Views
Last post June 05, 2017, 02:48:32 pm
by 3000 FPS