Chainsaw Repair

Husqvarna - Stihl - Poulan - Jonsered - Dolmar chainsaws and more => Homelite => Topic started by: echo user on December 07, 2015, 03:53:27 pm


Title: 925
Post by: echo user on December 07, 2015, 03:53:27 pm
I just picked up  a xl 925 it  has no spark .what is the test procedure  to test whats wrong
Title: Re: 925
Post by: fossil on December 07, 2015, 04:54:12 pm
The on - off switches are frequent fails on Homelites. To check it, disconnect the switch wire from the coil and try it again.

Failing that, check you plug wire connection at the coil, They will be faulty sometimes. They usually are screwed into the module / coil.

The last is to replace the plug with a fresh one. They don't fail often but I've had a few NGK's go out.

I hope it's that simple. Do you have the one piece or two piece coil/module? (I can't remember if the late models were one piece or not)

If it's two piece you will have a module under the flywheel. Make sure none of the wires are off or have **** insulation causing them to ground out the ignition.
Title: Re: 925
Post by: echo user on December 17, 2015, 10:07:02 pm
I crank it over by a drill it has erratic spark not constant . I unhook kill wire its the same I took it all apart .even removed flywheel and checked connections on module all looked good .any ideas ?
Title: Re: 925
Post by: Eccentric on December 18, 2015, 12:37:00 am
The three piece electronic ignition on these is problematic.  Homelite eventually sold a 'retrofit kit' to switch those saws to the later one piece ignition.  Had a replacement ignition bracket/bearing retainer, module, and flywheel.