Author Topic: MS 310 engine won't fire  (Read 261 times)

0 Members and 0 Guests are viewing this topic.

Offline Benn30

  • pruner
  • *
  • Posts: 4
  • Karma: 0
MS 310 engine won't fire
« on: July 05, 2014, 06:42:19 pm »
I've never had a problem with my 5 year old Stihl MS 310 until recently. The usual start procedure when cold is 3 or 4 pulls in the full choke and high throttle position which usually causes the motor to fire. Then a pull in the open choke and half throttle position will cause the engine to run and then on to normal run and low throttle . However, the engine now fails to even fire in any of the choke and throttle positions. I've installed a new spark plug and gaped it to .02" as specified in the manual, and ignition spark looks good. I replaced the fuel mix  with fresh ethanol 91 octane unleaded gas mixed with Stih's 50:1 synthetic 2 cycle oil. I replaced the carburetor with a new OEM Warbro carb and also replaced the air filter with a new one. I did notice that the fuel line to the carb was under a lot of pressure because it shot fuel about 5 feet when I pulled it loose. The only thing left that I can think of is the timing and cylinder compression. I've ordered a compression meter and will check that eventually. I'm guessing that the pressure should be somewhere around 130 psi , but I couldn't find the spec on it. The timing lock on the flywheel breaking or slipping  seems unlikely.  What have I overlooked here ?  Is there something else that I can check for this problem ?

Social Buttons


Offline Cut4fun .

  • Administrator
  • Nitro Hotsaw
  • *******
  • Posts: 19619
  • Karma: 403
  • OHIO REDNECK Saw Repair Getter Done
    • Redneck Chainsaw Repair
Re: MS 310 engine won't fire
« Reply #1 on: July 05, 2014, 07:34:45 pm »
Common issues. **** fuel lines, **** impulse line.  Check fuel filter and clean and check tank vent.

Try this test. Remove air filter. Hold throttle open and take a squirt bottle with fuel mix and squirt through carb. Release trigger and try and start now.
REDNECK Saw Repair Getter Done

Offline Benn30

  • pruner
  • *
  • Posts: 4
  • Karma: 0
Re: MS 310 engine won't fire
« Reply #2 on: July 05, 2014, 08:39:24 pm »
I tried the fuel squirt test before I placed the post. the engine still didn't fire. Also, the fuel that shot out when I removed the carb and attached lines was actually the impulse line rather than the fuel line. The line had to be ok or the pressurized fuel in it would have gotten out prior to pulling it. I notice that when I pull the spark plug after pulling on the start rope a few times, the plug is wet with fuel. I must have a flooding issue also.

Online 3000 FPS

  • Moderator
  • Nitro Hotsaw
  • *******
  • Posts: 4195
  • Karma: 242
  • Location: Carpenter, Wyoming
Re: MS 310 engine won't fire
« Reply #3 on: July 05, 2014, 11:15:58 pm »
If the plug is wet like you say then the saw is flooded.   

What I do is pull the plug and blow it off with some compressed air.   Then with the plug out pull the engine over a couple of times with the starter rope.   Then blow down the spark plug hole with compressed air and look for a spray from fuel.   Do this procedure, starter rope then compressed air until you see no more spray coming from the spark plug hole. 

Put the plug back in and put the choke in run mode and hold the throttle wide open and see if it will start.

If not pull the plug again and see if it is wet.  If it is then the needle in the carb could be stuck open and you need to rebuild the carb or you have no spark.
PP 505, 475, 445.

Offline Benn30

  • pruner
  • *
  • Posts: 4
  • Karma: 0
Re: MS 310 engine won't fire
« Reply #4 on: July 06, 2014, 12:07:26 am »
Thanks for your input...I'll definitely try your suggestions in the morning - hope it works.

Online 3000 FPS

  • Moderator
  • Nitro Hotsaw
  • *******
  • Posts: 4195
  • Karma: 242
  • Location: Carpenter, Wyoming
Re: MS 310 engine won't fire
« Reply #5 on: July 06, 2014, 12:15:34 am »
The other thing I do is gap all my plugs to .025.   I have not run into a 2 cycle engine yet that could handle that much gap and it does give a little larger spark.
PP 505, 475, 445.

Offline Benn30

  • pruner
  • *
  • Posts: 4
  • Karma: 0
Re: MS 310 engine won't fire
« Reply #6 on: July 06, 2014, 01:45:08 pm »
Well, the saw is finally running. After going through every step suggested, it still stubbornly refused to fire. I decided to give it one last try before giving up on the thing. I pulled the carb and the 2 connecting lines and and  a vent line (I guess) back to the  tank.  Verified that the vacuum pulse line  and diaphragm pump in carb were working and the fuel line and filter were clear - could hear the air pulse activate the pump. I sprayed Sea Foam through the carb ports and blew air into the ports (although the carb is new) and cylinder chamber.  Then put it all back together and cranked it 4 times in full choke and high throttle and it fired - open choke and half throttle got it running. Apparently lots of oil residue in the chamber because of much white smoke from the exhaust. But, it settled down and ran well.  I'm using 91 octane ethanol free gas in every small engine that I have now in the hope that I'll have less of these problems in the future.  I appreciate the help that I received here in troubleshooting this problem. 

Online 3000 FPS

  • Moderator
  • Nitro Hotsaw
  • *******
  • Posts: 4195
  • Karma: 242
  • Location: Carpenter, Wyoming
Re: MS 310 engine won't fire
« Reply #7 on: July 06, 2014, 02:51:54 pm »
The reason for so much smoke is probably due to a large amount of fuel sitting in the crankcase that evaporated off and left some of the oil behind.

The problem with 2 strokes when they flood is you really do not know how fuel is sitting in the crankcase.

Glad you got her going again.
PP 505, 475, 445.

 

Related Topics

  Subject / Started by Replies Last post
3 Replies
312 Views
Last post February 04, 2012, 10:28:30 am
by Cut4fun
0 Replies
492 Views
Last post October 09, 2012, 09:17:41 am
by yldflight
3 Replies
242 Views
Last post April 26, 2013, 08:19:54 pm
by Al Smith
54 Replies
850 Views
Last post February 09, 2014, 05:37:39 pm
by wbhburn
4 Replies
181 Views
Last post December 20, 2013, 04:15:22 pm
by Eccentric
10 Replies
165 Views
Last post February 23, 2014, 08:11:59 pm
by 350XP
3 Replies
94 Views
Last post February 01, 2014, 01:41:28 pm
by KilliansRedLeo
11 Replies
293 Views
Last post May 05, 2014, 10:27:49 pm
by Phillip Guidry
8 Replies
220 Views
Last post May 25, 2014, 12:26:46 pm
by SawDawg
1 Replies
371 Views
Last post October 13, 2014, 07:50:10 pm
by sharkey