Author Topic: Echo 58 volt chainsaw  (Read 147 times)

0 Members and 0 Guests are viewing this topic.

Offline Jake333

  • pruner
  • *
  • Posts: 1
  • Karma: 1
Echo 58 volt chainsaw
« on: December 30, 2016, 06:04:06 pm »
I have had this chainsaw since March 2016.  It cuts fine when it is working but I am having a problems.  First, my battery died last week, Echo sent me a new one within 7 days over Christmas.  Pretty impressive, but not if you want to use your chainsaw.  Today it threw a chain, which I think it does too easily.  When it does this it always messes up the chain and you have to file it to get it run again.  But today the big issue is that after I put the chain back on, the saw would not start.  No nothing.  For 10 minutes nothing worked.  Then I noticed a rattle in the trigger housing.   There was a problem between the trigger release and the trigger.  After turning the saw over, the interface was re-established and the chainsaw started.  By the way Home Depot tool rental is the authorized repair center and there turn around time is 3 weeks.  Not good.

Social Buttons

Useful Useful x 1 View List

 

Related Topics

  Subject / Started by Replies Last post
3 Replies
491 Views
Last post January 08, 2015, 07:19:47 pm
by Cut4fun .
8 Replies
222 Views
Last post September 28, 2013, 03:47:02 pm
by Cut4fun .
19 Replies
461 Views
Last post November 01, 2013, 02:40:11 pm
by leec
8 Replies
4200 Views
Last post April 29, 2016, 08:01:58 pm
by chy_farm
8 Replies
412 Views
Last post December 27, 2014, 12:06:22 pm
by Eccentric
30 Replies
3424 Views
Last post March 24, 2016, 01:46:54 pm
by Tintcutter
1 Replies
157 Views
Last post March 29, 2015, 01:01:09 pm
by Fishnuts2
echo cs-310

Started by Cut4fun . « 1 2 » Echo

11 Replies
508 Views
Last post March 24, 2016, 03:01:43 pm
by leec
2 Replies
251 Views
Last post November 09, 2015, 07:18:27 am
by Cut4fun .
2 Replies
262 Views
Last post November 08, 2015, 01:12:42 pm
by Cut4fun .